[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4284: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4286: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4288: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
CULA • View topic - CULA Device

CULA Device

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

CULA Device

Postby jezz0r » Wed Jul 17, 2013 8:32 am

Hi,
I'm getting much slower results when launching culaDeviceSgesv than culaSgesv on very similar matrices/RHSs. Why is this?
jezz0r
 
Posts: 5
Joined: Tue Jul 02, 2013 6:39 am

Re: CULA Device

Postby jezz0r » Wed Jul 17, 2013 8:42 am

Actually, on identical systems, I just checked, the problem is the same: the device version is about three times as slow
jezz0r
 
Posts: 5
Joined: Tue Jul 02, 2013 6:39 am

Re: CULA Device

Postby john » Wed Jul 17, 2013 8:53 am

The host interface takes certain liberties with how the data sits on card (since we own that data, not the user). Sometimes it can work out to a decent little speed boost, but not usually 3x. It's hard to say without more detail from you.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm

Re: CULA Device

Postby jezz0r » Thu Jul 18, 2013 6:07 am

jezz0r
 
Posts: 5
Joined: Tue Jul 02, 2013 6:39 am

Re: CULA Device

Postby john » Thu Jul 18, 2013 9:56 am

Be sure to include a "warmup" run in your testing. The first hit to the GPU will cause things like kernels being loaded down to the card.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm

Re: CULA Device

Postby jezz0r » Fri Jul 19, 2013 1:44 am

To be clear, that is the output from one program, and does not even include the first run. It solves this thing repeatedly, and updates certain values from the result.
jezz0r
 
Posts: 5
Joined: Tue Jul 02, 2013 6:39 am

Re: CULA Device

Postby john » Fri Jul 19, 2013 5:39 am

It's impossible to really be helpful without a complete test program with data, but I can keep giving one-off suggestions. You should try padding your matrix to an even multiple of 16, 32, 64, etc (try a few different ones to see what your GPU likes.) Just remember to make the padded portions into the identity matrix rather than just zeroes (all zeroes would be singular.) You could also just pad LDA, but I find it easier to do N=LDA.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to CULA Dense Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests

cron