Error in running the example

Support for issues specific to the Windows operating systems.

Error in running the example

Postby pshi » Mon Apr 25, 2011 5:43 am

After installing the cula premium,I run the example geqrf and it failed.The error description is shown below.

Error 1 error C2719: 'alpha': formal parameter with __declspec(align('8')) won't be aligned c:\program files\cula\include\culapack.h 82 geqrf
Error 2 error C2719: 'beta': formal parameter with __declspec(align('8')) won't be aligned c:\program files\cula\include\culapack.h 82 geqrf
Error 3 error C2719: 'alpha': formal parameter with __declspec(align('16')) won't be aligned c:\program files\cula\include\culapack.h 248 geqrf
Error 4 error C2719: 'beta': formal parameter with __declspec(align('16')) won't be aligned c:\program files\cula\include\culapack.h 248 geqrf


What problem may it be? And how to solve this problem? Thanks for your answer!
pshi
 
Posts: 1
Joined: Wed Apr 20, 2011 12:29 am

Re: Error in running the example

Postby john » Mon Apr 25, 2011 6:42 am

Please try
#define CULA_USE_CUDA_COMPLEX
... place this prior to all CULA includes.

Are you compiling 32-bit? This shouldn't be a problem under 64-bit but is known to happen in 32.

The next release of CULA should be a little more graceful about this. Thanks for your patience.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to Windows Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron