Page 1 of 1

Runtime Error (8)

PostPosted: Tue May 11, 2010 5:38 am
by elocica
Hi,
I get a runtime error with error code 8 when i try to use the cudaGesvd or cudaGetri, or cudaGetrf, while the CUDA blas functions (cublasSgemm) i am using are working fine. I am using the cublas and cudart libs provided by cula. I also tried uninstalling CUDA completely so that i don't accidentally use wrong libraries, but the same problem occurs.
The matrix sizes i tried are small (50,100, 1500).

I am using win 7, i have NVIDIA GeForce GTX 480 and i have CUDA 2.3 and CULA 1.3a installed. I have installed the latest drivers.

Any ideas on what went wrong?

Thank you,
Consuela

Re:Runtime Error (8)

PostPosted: Tue May 11, 2010 6:12 am
by john
CULA doesn't yet support Fermi class cards (such as the GTX480.) We'll be doing a release very soon for that, likely this week.

It is difficult for us to detect cards that are newer than what was supported at the time of a CULA release so I'm afraid that we couldn't make a nice error for that condition. Ideally it would say "hardware too new; unsupported by this version" but instead it ran and produced garbage data (runtime error 8 is a data error). Hopefully we'll have you up and running very soon.

Re:Runtime Error (8)

PostPosted: Tue May 11, 2010 6:19 am
by elocica
Thank you for the very fast reply.
i'm waiting for the new cula version :)