CULA intialization error

Support for issues specific to the Windows operating systems.

CULA intialization error

Postby saurabh321 » Tue Aug 13, 2013 12:20 am

Hello everyone,
We have Quadro FX 1800 GPU card and installed CUDA 5.0. Also installed CULA full free version. Now we are trying for basic CULA sample code i.e. initialize & shutdown but there was following errors:
error LNK2019: unresolved external symbol _culaShutdown referenced in function _main
error LNK2019: unresolved external symbol _culaInitialize referenced in function _main
error LNK2019: unresolved external symbol _culaGetErrorInfoString referenced in function

We had setup all environment required for CULA as per Users Guide.

Even there was an error in another program like:

unresolved external symbol _culaGetCudaDriverVersion referenced in function _main
unresolved external symbol _culaGetCudaRuntimeVersion referenced in function _main
unresolved external symbol _culaGetCudaMinimumVersion referenced in function _main

So we are thankful if you solve our problem.
saurabh321
 
Posts: 1
Joined: Wed Aug 07, 2013 12:11 am

Re: CULA intialization error

Postby john » Tue Aug 13, 2013 6:00 am

You'll need to read the linking section of the guide or check out the examples for how to link the library correctly. That's all your problem appears to be.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to Windows Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron