Page 1 of 1

CUDA driver error

PostPosted: Mon Jan 23, 2012 11:39 am
by dandan
Hi,

I am running my code on a machine enhanced with Tesla M2050 cards. When I run CULA sparse example codes on this machine, I get this error:

CUDA Error: CUDA driver version is insufficient for CUDA runtime version (see Programmer's Guide)

I know that the CUDA installed on this machine in CUDA 3.2 and CULA sparse requires CUDA 4.0, so I wanted to make sure if the CUDA on this machine will be upgraded to the latest version (CUDA 4.0) which is a requirement for CULA sparse, will the problem be resolved or this problem is due to something else?

Regards,

Dan

Re: CUDA driver error

PostPosted: Mon Jan 23, 2012 12:46 pm
by john
You're thinking is correct. Our driver requirements are indeed hard requirements and so must be at least equal to the stated required version. We would recommend updating your driver regularly, even if you do not update your CUDA toolkit very often.