upgraded to Cula Dense: wont link

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

upgraded to Cula Dense: wont link

Postby jmorgie » Mon Dec 19, 2011 6:06 pm

I just upgraded to Cula R13. set the library, etc.

Link fails, complaining about every cula call in the program. why?

I am also upgrading to cuda 4.1; is this the cause of the linker failing?
do you have a clue when Culatools will upgrade to Cuda 4.1 ??

thanks
==================
Link command:
OUT:"U:\ImageMining\Vision4ce\V4MH\V4MH\msi_objects32\Debug\msi_objects.exe" /INCREMENTAL /NOLOGO /LIBPATH:"U:\ImageMining\Vision4ce\tiff\lib\" /LIBPATH:"C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.1\lib\Win32" /LIBPATH:"C:\Program Files\CULA\R13\lib64" /LIBPATH:"U:\ImageMining\Vision4ce\GripWorkx303\lib" /LIBPATH:"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v4.1\lib\Win32" "cuda.lib" "cudart.lib" "cula_core.lib" "cula_lapack.lib" "cula_lapack_link.lib" "V4Corelib.lib" "libtiff.lib" "kernel32.lib" "user32.lib" "gdi32.lib" "winspool.lib" "comdlg32.lib" "advapi32.lib" "shell32.lib" "ole32.lib" "oleaut32.lib" "uuid.lib" "odbc32.lib" "odbccp32.lib" /MANIFEST /ManifestFile:"Debug\msi_objects.exe.intermediate.manifest" /ALLOWISOLATION /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /DEBUG /PDB:"U:\ImageMining\Vision4ce\V4MH\V4MH\msi_objects32\Debug\msi_objects.pdb" /SUBSYSTEM:CONSOLE /PGD:"U:\ImageMining\Vision4ce\V4MH\V4MH\msi_objects32\Debug\msi_objects.pgd" /TLBID:1 /DYNAMICBASE /NXCOMPAT /MACHINE:X86 /ERRORREPORT:QUEUE
jmorgie
 
Posts: 6
Joined: Wed Sep 29, 2010 8:48 am

Re: upgraded to Cula Dense: wont link

Postby john » Tue Dec 20, 2011 6:22 am

Without actually seeing the errors produced, I can only speculate.

In your linker command I can clearly see that you are mixing 32-bit and 64-bit libs - you will need those to be consistent, for sure.

Edit: You have also indicated that you have installed CUDA 4.1 RC (I say RC because CUDA 4.1 is only available in Release Candidate build presently), but CULA R13 is based against CUDA 4.0. Forward compatibility with future CUDA versions is allowed, but unsupported, so your mileage may vary. Again, with no errors shown I can merely guess. A CUDA 4.1 version of CULA will be released very shortly after CUDA 4.1 is released.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron