Page 1 of 1

undefined symbol: culaGetOptimalPitch

PostPosted: Sat Apr 16, 2011 10:37 am
by timeu
Hi all
I tried to evaluate PyCULA on my machine (core i7, Quadro FX 580).

However when importing PyCULA (from PyCULA.cula import *) I get following error:

/usr/local/cula/lib64/ undefined symbol: culaGetOptimalPitch

I am using the basic version of cula 2.1. Is this an issue of the basic version?

Here are some additional information on the setup:
CUDA3.2 toolkit and latest release driver (260.19.26)
PyCUDA trunk
cula 2.1 basic

ldd on
ldd /usr/local/cula/lib64/ => (0x00007fffccdff000) => /usr/lib/ (0x00007ffc5e997000) => /usr/local/cula/lib64/ (0x00007ffc5b905000) => /usr/local/cula/lib64/ (0x00007ffc5b6c9000) => /usr/lib/ (0x00007ffc5b4bb000) => /lib/ (0x00007ffc5b2b3000) => /lib/ (0x00007ffc5b02f000) => /lib/ (0x00007ffc5ae18000) => /lib/ (0x00007ffc5abfb000) => /lib/ (0x00007ffc5a877000)
/lib64/ (0x00007ffc6063c000) => /lib/ (0x00007ffc5a673000)

thanks in advance

Re: undefined symbol: culaGetOptimalPitch

PostPosted: Mon Apr 18, 2011 6:44 am
by john
I do believe that PyCULA is meant to be used with CULA Premium.

The calls to culaGetOptimalPitch aren't necessary for functionality, so you could define your own version to return *pitch equal to rows. That said, in many cases, culaGetOptimalPitch will lead to a sometimes significant speed gain over this approach.

Re: undefined symbol: culaGetOptimalPitch

PostPosted: Fri Nov 18, 2011 8:17 am
by somusshabadi
Hi all,

I am having exactly the same error as above.
somuss@jackie:~/louistheran-pycula-example/PyCULA/examples$ python
Traceback (most recent call last):
File "", line 12, in <module>
from PyCULA.cula import *
File "/usr/local/lib/python2.5/site-packages/PyCULA-0.95a1-py2.6.egg/PyCULA/", line 140, in <module>
_culaGetOptimalPitch = libcula.culaGetOptimalPitch
File "/usr/local/lib/python2.5/ctypes/", line 361, in __getattr__
func = self.__getitem__(name)
File "/usr/local/lib/python2.5/ctypes/", line 366, in __getitem__
func = self._FuncPtr((name_or_ordinal, self))
AttributeError: /usr/local/cula/lib64/ undefined symbol: culaGetOptimalPitch

I have installed CULA Dense R12 (Free edition) on Ubuntu. How do i resolve this error?

Thanking you in advance !


Re: undefined symbol: culaGetOptimalPitch

PostPosted: Mon Dec 05, 2011 11:53 am
by john
This routine is not included in the free version of CULA. This should be accounted for by PyCULA. You can edit the PyCULA code to work around this requirement.