Page 1 of 1

Runtime error with CULA initialization

PostPosted: Mon Oct 25, 2010 2:16 pm
by jimmysu
Hi,
I am trying to run the "benchmark" program under the "examples" directory. Actually I get the same error on other CULA examples as well. Below is a brief summary of my set up. The output from sysinfo.sh is attached to this post.

GPU: Nvidia Quadro FX 3800
OS: Linux openSUSE 11.1 64 bit
CUDA: release 3.0, V0.2.1221
CULA: version 2.1 64 bit

I get the following error when I tried to run the "benchmark" program:

optillel@optillel-8xamd:~/cula/examples/benchmark> ./benchmark
Initializing CULA...
CULA failed to initialized with error message:Runtime error, see culaGetErrorInfo for error code.

I added a printf to the program to print culaGetErrorInfo, and I got the following:

culaGetErrorInfo 35

What does this error code mean? We ran benchmarks that came with the CUDA installation, and those GPU benchmarks run fine on this machine. Any insights will be greatly appreciated. Thank you very much for your help.

Jimmy

Re: Runtime error with CULA initialization

PostPosted: Tue Oct 26, 2010 8:15 am
by kyle
Be sure that your drivers are update to date. CULA 2.1 for Linux requires drivers of at least version 256.40. According to your system info, you are using an older version of the NVIDIA drivers.

If you cannot update your drives, you can try CULA 2.0 which should work with your current drivers. The Linux 64-bit version can be downloaded here:

http://www.culatools.com/files/cula/2.0 ... inux64.run