Run time error 8 problem

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

Run time error 8 problem

Postby jlicula » Wed Oct 13, 2010 10:40 pm

I have recently installed CULA 1.3a on my 64 bit linux with CUDA 3.0, but I am getting run time error while I am running some CULA examples. I think it is a version compatability problem, and I am wonder what is the best solution. Here is the information for my system:

We recently bought a 64 bit linux machine with 3 Telsla C2050 GPUs. The system is CentOS 5.3, CUDA 3.0. The NVIDIA driver is 195.36.24

First, I tried CULA 2.1, and the test compilation of the examples failed.
Then, I uninstalled 2.1 and installed version 1.3a. The compilation passed, but when I ran the test cases, I got the run time error.

I am wondering if I can get CULA 2.0, which may have better compatability with my CUDA configuration.

I would like to get some expert suggestions before I change driver/CUDA versions.

Thank you.
jlicula
 
Posts: 2
Joined: Tue Oct 12, 2010 12:30 pm

Re: Run time error 8 problem

Postby kyle » Thu Oct 14, 2010 5:43 am

Here is the download link to CULA 2.0 for Linux 64:

http://www.culatools.com/files/cula/2.0 ... inux64.run

We'd highly recommend upgrading when CUDA 3.2 is released. Combined with CULA 2.2, there will be over a 2x speedup for many routines on the Fermi architecture.
kyle
Administrator
 
Posts: 301
Joined: Fri Jun 12, 2009 7:47 pm

Re: Run time error 8 problem

Postby jlicula » Thu Oct 14, 2010 11:23 am

Thank you for your quick reply.

What is the time schedule for CULA 2.2? and what will be the CUDA and Driver versions based on?

I checked CULA 2.0, it is based on CUDA 3.1 and driver 256.35, not quit match to my current setting.

I have a quick question: what is the version compatability in general? backward or forward compatable? or we need use the exact matching versions for CUDA and driver? What is the compatablity with OS versions? In particular in my case, CentOS 5.3?

Jiabo
jlicula
 
Posts: 2
Joined: Tue Oct 12, 2010 12:30 pm

Re: Run time error 8 problem

Postby john » Thu Oct 14, 2010 12:23 pm

You are free to use a newer driver. The driver must be newer or equal to the code that it was built against.

CULA 2.2 will be based on the 3.2 RC that is currently available.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron