CULA and GTX 480

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

CULA and GTX 480

Postby Boxed Cylon » Thu May 13, 2010 11:24 am

I see from an e-mail search that CULA does not quite support the new Fermi cards yet, such as the new GTX 480 I've just installed in my computer... I post this just to make this explicit, should anyone else be wondering.

By disabling "status" checks, I can get CULA to run, using my favorite sgesv, but the answers are wrong. It runs rather quickly (30X over CPU), but perhaps that's not meaningful.

The usual CUDA test applications/tests seem to run just fine, so I think I am good to go. (yay.)

The hints on this forum suggest that Fermi-based cards will be supported soon, and I have no real urgency (other than the to-be-expected curiosity of how well the GTX 480 will do compared to my GTX 260). So standing by... :)
Boxed Cylon
 
Posts: 48
Joined: Fri Oct 16, 2009 8:57 pm

Re:CULA and GTX 480

Postby kyle » Sat May 15, 2010 7:45 am

NVIDIA currently has some known issues with CUBLAS' performance in 3.0. These bugs cripple the performance of CULA so we are waiting for an update from NVIDIA before we will release an updated CULA.

Luckily, we've been working with NVIDIA to identify and resolve these issues and a new version of CUBLAS will be out very shortly. Once the CUBLAS fix is available, an updated version of CULA for CUDA 3.0 should be available soon there after!
kyle
Administrator
 
Posts: 301
Joined: Fri Jun 12, 2009 7:47 pm

Re:CULA and GTX 480

Postby john » Fri May 21, 2010 3:31 pm

CULA 2.0 has been posted for download in a preview state. Please see http://www.culatools.com/forums/13-news ... -available for details.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron