Has CULA errors in CUDA 3.0?

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

Has CULA errors in CUDA 3.0?

Postby Rockfactory Chief » Mon Mar 01, 2010 12:46 am

Hi. I'm Jason from Republic of Korea.

First of all, I can't speak English well.
I really really sorry.

I used CULA for solution of SVD and regression
Mt program made by CUDA 2.3 & CULA 1.0.
My environment is Windows XP 32bit and Visual Studio 2008.

However 1 week ago, I did upgrade CUDA 3.0.
Then, all of my programs did not work.
It occurred some errors.
Error message is a kind of dll missing error(especially cublas.dll and cudart.dll)

So, I did upgrade CULA 1.2
And I did copy cublas.dll and cudart.dll in CULA install folder to working folder.
Then another error occurred.
Message is a kind of casting or function error.

So I guess CULA 1.0 to 1.2 does not support CUDA 3.0.
Is it right or not?
If somebody knows this problem, then please help me.



Best Regards,
Jason Park
Rockfactory Chief
 
Posts: 2
Joined: Mon Aug 17, 2009 12:37 am

Re:Has CULA errors in CUDA 3.0?

Postby dan » Tue Mar 02, 2010 8:04 am

CULA doesn't yet support CUDA 3.0, note that this software hasn't been officially released and is still in the beta stage.

Your errors are likely related to the fact that you're compiling against CUDA 3.0 (and possibly compile time link against 3.0) but trying to runtime link against CUDA 2.3 libraries. The best solution to this problem is to revert back to CUDA 2.3.
dan
Administrator
 
Posts: 61
Joined: Thu Jul 23, 2009 2:29 pm

Re:Has CULA errors in CUDA 3.0?

Postby Rockfactory Chief » Tue Mar 02, 2010 5:38 pm

Thanks!!!

Your comment is very helpful to me.

I appreciate your help. :)
Rockfactory Chief
 
Posts: 2
Joined: Mon Aug 17, 2009 12:37 am


Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron