Page 1 of 1

libcula_lapack.so not found in lib and lib64 directories

PostPosted: Wed Feb 25, 2015 3:21 pm
by dared90
Hi guys,
I downloaded CULA Dense R17 Free Edition for Linux.

I noticed that in lib and lib64 directories, there isn't libcula_lapack.so but there is only libcula_lapack_basic.so. Is it normal?

I set environment variables in .bashrc file in this way:
export CULA_LIB_PATH_32=/usr/local/cula/lib
export CULA_ROOT=/usr/local/cula
export CULA_LIB_PATH_64=/usr/local/cula/lib64
export CULA_INC_PATH=/usr/local/cula/include
export LD_LIBRARY_PATH = "$CULA_LIB_PATH_64"


I tried to compile a very simple c program to test if cula run correctly.

Code: Select all
#include <cula.h>
#include <stdio.h>

int main()
{
    culaStatus s;
    s = culaInitialize();
    if (s != culaNoError)
       printf("%s\n", culaGetStatusString(s));

    culaShutdown();
    return 0;
}


I compile with:
gcc -I$CULA_INC_PATH -L$CULA_LIB_PATH_64 -lcula_lapack_basic prog.c -o prog

I received this errors:
/tmp/ccDSdmLN.o: In function `main':
prog.c:(.text+0xe): undefined reference to `culaInitialize'
prog.c:(.text+0x21): undefined reference to `culaGetStatusString'
prog.c:(.text+0x33): undefined reference to `culaShutdown'
collect2: ld returned 1 exit status


How to resolve this compilation problem? :roll: :roll: :(

Re: libcula_lapack.so not found in lib and lib64 directories

PostPosted: Wed Oct 14, 2015 3:38 am
by zhongjs52
Hi,

I do have the same issue.

Have you solved this problem?