CULA R18 Compatible w/CUDA 6.5 ?

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

CULA R18 Compatible w/CUDA 6.5 ?

Postby grahamr » Mon Dec 01, 2014 10:36 am

I recently upgraded to an Nvidia GTX 980 card. The Nvidia CUDA site directs 980 users to download CUDA version 6.5. It looks like CULA R18 was built for CUDA 6.0. Does anyone know if CULA R18 will work with CUDA 6.5, OR if the GTX 980 will work with CUDA 6.0 ?

I am using the LAPACK routine cula_sgetrf (matrix LU decomposition) under Win64/Intel compiler. The routine appears to work up to a matrix size 0f 629x629, but fails at 630x630. When it fails CULA_CHECK_STATUS returns - CUDA Error: invalid texture reference (see Programmers Guide).

Note: When the cula routine works, comparing the cula_sgetrf factored matrix with the Intel MKL factorization, the Std Dev between the corresponding elements of the matrix is order 1.0E-05. So I believe it is functioning properly up to the 629x629 size...

Thanks
grahamr
 
Posts: 1
Joined: Mon Nov 15, 2010 7:38 pm

Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron