Page 1 of 1

culaCgels runtime_error(10)

PostPosted: Tue Oct 21, 2014 10:24 pm
by joshua_sendall
Hi,

I am trying to solve a large least squares solution using Cgels which works great for smallish matrices (when A is around 6000 elements). However, when the size of the matrix is increased by about a decade the function throws a culaRuntimeError (10).

I have tried to find information about runtime error codes to no avail, so if someone could point me in the correct direction it would be much appreciated.

Regards,
Josh

Re: culaCgels runtime_error(10)

PostPosted: Mon Mar 09, 2015 6:37 am
by ipolok
I have the same problem. I'm solving a (dense) Cholesky decomposition, with double precision real matrices. Works fine for small matrices. For large matrices, error 10 (culaRuntimeError), error info 8 (no idea what that means). The same matrices can be solved with no problem using Eigen, or after conversion to sparse even using CSparse. What's the deal?

I have tried using LU decomposition which improved on some matrices, but anything above 1000 elements again error 10 (culaRuntimeError), error info 8. This is useless.

I'm guessing your library is a hybrid one and CPU version of the kernels is used for small matrices. The GPU version then fails on large matrices. Sounds about right?

My hardware is GTX 680.

Could someone from CULA team respond, please?

Re: culaCgels runtime_error(10)

PostPosted: Mon Mar 09, 2015 11:08 am
by ipolok
Nevermind. I've noticed there is a newer version of CULA (R18) and the problem went away.