Unable to run example from CULA Dense R17

General CULA Dense (LAPACK & BLAS) support and troubleshooting. Use this forum if you are having a general problem or have encountered a bug.

Unable to run example from CULA Dense R17

Postby fninaparavecino » Tue Jan 21, 2014 2:30 pm

This is my first time working with CULA (I have been working with CUDA for a while). I installed CULA_DENSE_R17 on Ubuntu 13.04, with CUDA 5.5. My graphic card is an NVIDIA GTX TITAN and after I installed. I added the enviroment variable as follow:
export CULA_ROOT="/home/fnina/CULA_samples"
export CULA_INC_PATH="$CULA_ROOT/include"
export CULA_LIB_PATH_32="$CULA_ROOT/lib"
export CULA_LIB_PATH_64="$CULA_ROOT/lib64"

And also updated my ld.so.conf
But When I want to compile using "make build64" basicUsage from the example folder I got the following error:

sh ../checkenvironment.sh
gcc -m64 -o basicUsage basicUsage.c -DNDEBUG -O3 -I/home/fnina/CULA_samples/include -L/home/fnina/CULA_samples/lib64 -lcula_lapack -lcublas -lcudart -liomp5
/usr/bin/ld: cannot open output file basicUsage: Permission denied
collect2: error: ld returned 1 exit status
make: *** [build64] Error 1

I change to different folder my samples and still is not working properly, I tried with other example and got the same error. I would appreciate some lights here, to pointed me what it is supposed I'm missing?

Thanks in advance.
Posts: 1
Joined: Thu Apr 11, 2013 11:08 am

Return to CULA Dense Support

Who is online

Users browsing this forum: No registered users and 2 guests