Page 1 of 1

Support for CUDA Toolkit 4 soon?

PostPosted: Tue Mar 08, 2011 8:15 am
by athlonshi
Hi,
Will the CULA new release support CUDA Toolkit 4 soon?
I found the current CULA code does not support CUDA 4RC due to incompatible CUBLAS.
Thanks,
Yu

Re: Support for CUDA Toolkit 4 soon?

PostPosted: Tue Mar 08, 2011 8:37 am
by john
We cannot release against the CUDA 4 toolkit while it remains for developers-only. It is likely that we will have to wait for the CUDA 4 general availability. That said, we have been testing against 4.0 for several weeks now and CULA is 100% functional. Our CULA release will closely follow general availability of CUDA 4.0.

Re: Support for CUDA Toolkit 4 soon?

PostPosted: Tue Mar 08, 2011 8:39 am
by athlonshi
Thanks, John!
That is what I thought of. I look forward to the new release once NVIDIA officially launches CUDA 4.

Re: Support for CUDA Toolkit 4 soon?

PostPosted: Mon Mar 14, 2011 12:23 pm
by bzell
In the post it says cula is 100% functional with 4.0. BUT does that
> mean I CAN use cula with 4.0 now or do I have to wait for you all to
> release a build specific to cuda 4.0?
>
> Color me confused.
>

Re: Support for CUDA Toolkit 4 soon?

PostPosted: Mon Mar 14, 2011 12:36 pm
by john
That's a good question. Since we rely on both the CUDA runtime and on CUBLAS, we are strictly tied to running on the same version as we compiled against and as we shipped in the CULA toolkit. This is even moreso important in CUDA 4 due to the changes in the CUBLAS API.

That said, we cannot create a release against CUDA 4 until it comes out of developer release. I'm afraid that means that CULA customers will have to wait a bit.