CULA 2.1 does not work on OS X 10.5

Support for issues specific to the Mac OS operating systems.

CULA 2.1 does not work on OS X 10.5

Postby desaprobado » Thu Nov 25, 2010 2:05 pm

Hi,

The version of libcula.dylib in CULA 2.1 does not work on 10.5. The dynamic loader gives the following error

Code: Select all
/usr/local/cula/lib/libcula.dylib: unknown required load command 0x80000022


From what I can tell, this is a common problem with libraries that are compiled on a 10.6 system and then used on a 10.5 system.

You may be able to avoid it by making sure that the flag -mmacosx-version-min=10.4 is set for the linker as well as for the compiler.

Version 2.0 does not have this problem and seems to work fine on OS X 10.5

Cheers

Will
desaprobado
 
Posts: 1
Joined: Thu Nov 25, 2010 12:59 pm

Re: CULA 2.1 does not work on OS X 10.5

Postby john » Fri Dec 10, 2010 10:37 am

Hi Will,
Unfortunately we were not able to complete this work for the R10 release. It turns out that there is a bit more to it than just the compiler flag. We are elevating the priority on this issue for the R11 release.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron