[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4284: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4286: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4288: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
CULA • View topic - CULA R10 and pycuda
Page 1 of 1

CULA R10 and pycuda

PostPosted: Wed Jan 12, 2011 3:59 pm
by levgivon

Re: CULA R10 and pycuda

PostPosted: Wed Jan 12, 2011 6:24 pm
by psillymathhead
Hey Lev,

I could not reproduce your error. I replied to your post on the PyCUDA mailing list:

I have the following setup and cannot reproduce your error from the test snippet. I spent a few minutes changing my PATH and LD_LIBRARY_PATH to see if I could break it.

CUDAtoolkit 3.2.16
CUDA devdriver 260.19.26
PyCUDAv2011.1
CULA-R10

I had such failures with CUDA-RC, RC2 and some devel versions. Once the release versions of the various packages were all released I was able to get all the libraries to work simultaneously for my PyCULA project, including those from your scikit...

Can you give more detail as to what you are running?

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 7:03 am
by levgivon
My system is running

CUDA toolkit 3.2.16
NVIDIA driver 260.19.29
PyCUDA 0.94.2
Python 2.6.5
CULA premium R10 for x86_64
The latest development release of scikits.cuda (available on github).

The GPU is a GTX 260. The CUDA toolkit libraries are installed in
/usr/lib64; the CULA libraries are installed in
/usr/lib64/cula_premium (with a file in /etc/ld.so.conf.d containing
that path).

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 7:59 am
by psillymathhead
Is that devdriver an Nvidia Developer (or beta) version? It was not listed on their "Get CUDA" website. I had such issues with devel versions before (including the RC versions)... Can you try rolling back your driver to 260.19.26 to see if it resolves the issue? I will try to find your driver version after breakfast. At least we may narrow down something reproducible...

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 9:03 am
by psillymathhead
With 260.19.29 I still cannot reproduce. What are your $PATH and $LD_LIBRARY_PATH?... I noticed you are using a non-standard install location; perhaps you are catching the wrong libs from a different install version?

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 9:47 am
by john
Those appear to be the right drivers to match the installed toolkit (listed at www.nvidia.com/getcuda). It's probably worth running ldd to check what's being loaded.

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 10:01 am
by psillymathhead
Hi John,

I think Lev was able to resolve the issue by rebuilding the PyCUDA package against the newer CUDA install.

Re: CULA R10 and pycuda

PostPosted: Thu Jan 13, 2011 10:30 am
by john
Great news!