centos 5 not supported?

Support for issues specific to the Linux operating systems.

centos 5 not supported?

Postby ksong » Thu Oct 07, 2010 1:38 pm

Hi, I am new to CULA as well as CUDA in general. When I try to download CULA, I can't find a suitable linux OS:
Linux (64-bit)
Linux (32-bit)
RHEL 4.8 (64-bit)
RHEL 4.8 (32-bit)

I have tried to downloaded both, but they have competiability issues:
$ gcc -o test -I$CULA_INC_PATH -L$CULA_LIB_PATH_32 -lcula -lcublas -lcudart test.c
/usr/bin/ld: skipping incompatible /usr/local/cula/lib/libcula.so when searching for -lcula
/usr/bin/ld: cannot find -lcula
collect2: ld returned 1 exit status

Do I miss something simple?

Thanks,

Kai
ksong
 
Posts: 1
Joined: Tue Oct 05, 2010 3:13 pm

Re: centos 5 not supported?

Postby john » Fri Oct 08, 2010 5:47 am

You want the plain Linux version. If you're getting the incompatible warning, then you should be using the 64-bit version rather than 32-bit. Switch to -L/usr/local/cula/lib64 and it should work.
john
Administrator
 
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm


Return to Linux Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron