CULA on Ubuntu 10.04

Support for issues specific to the Linux operating systems.

CULA on Ubuntu 10.04

Postby vahuja4 » Wed Apr 17, 2013 10:57 am

I have defined the CULA environment variables in .bashrc. Here is the output from env| grep -i "cula":


Now, when I compile one of the examples that come along with CULA, here is what I get:

$ sudo make build32
sh ../
Warning: CULA_ROOT is not defined
Warning: CULA_INC_PATH is not defined
Warning: CULA_LIB_PATH_32 is not defined
Warning: CULA_LIB_PATH_64 is not defined

Warning: Some CULA environment variables could not be found.
This may prevent successful building of the example projects

gcc -m32 -o basicUsage basicUsage.c -DNDEBUG -O3 -I -L -lcula_core -lcula_lapack -lcublas -lcudart
basicUsage.c:61:25: error: cula_lapack.h: No such file or directory
basicUsage.c:64: error: expected ‘)’ before ‘status’
basicUsage.c: In function ‘main’:
basicUsage.c:88: error: ‘culaStatus’ undeclared (first use in this function)
basicUsage.c:88: error: (Each undeclared identifier is reported only once
basicUsage.c:88: error: for each function it appears in.)
basicUsage.c:88: error: expected ‘;’ before ‘status’
basicUsage.c:100: error: ‘status’ undeclared (first use in this function)
make: *** [build32] Error 1
Posts: 1
Joined: Wed Apr 17, 2013 9:06 am

Re: CULA on Ubuntu 10.04

Postby john » Wed Apr 17, 2013 10:59 am

Sudo changes your user, and you've changed it to a user who doesn't have those environment variables. This is why the makefile warns you.
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm

Re: CULA on Ubuntu 10.04

Postby albeam » Tue May 14, 2013 10:40 am

I am having this same error, even though I'm on Ubuntu 12.04. I have the following in both ~/.bashrc and /etc/bash.bashrc

## CULA Paths ##
export CULA_ROOT=/usr/local/cula

export CULA_INC_PATH=$CULA_ROOT/include

export CULA_BIN_PATH_32=$CULA_ROOT/bin

export CULA_BIN_PATH_64=$CULA_ROOT/bin64

export CULA_LIB_PATH_32=$CULA_ROOT/lib

export CULA_LIB_PATH_64=$CULA_ROOT/lib64

but I get the same error message as above.
Posts: 1
Joined: Tue May 14, 2013 10:01 am

Re: CULA on Ubuntu 10.04

Postby john » Tue May 14, 2013 2:12 pm

If you can't get your environment variables to cooperate, you could also edit the Makefiles to hardcode the paths yourself.
Posts: 587
Joined: Thu Jul 23, 2009 2:31 pm

Return to Linux Support

Who is online

Users browsing this forum: No registered users and 1 guest